Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Launcher Problem: Can't connect to server | Forums

  1. #1
    Junior Member
    Join Date
    Aug 2012
    Posts
    7

    Launcher Problem: Can't connect to server

    My internet is working just fine and the launcher says it can't find the server yet it can confirm that the server is "On". Help?
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Aug 2012
    Posts
    8
    I have the same problem with you. Anyone able to help ?
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Aug 2012
    Posts
    7
    I've also checked to see if my firewall was allowing access, it is; and I'm currently trying to uninstall and reinstall the program but it will not allow me to uninstall. When I try to uninstall the game it stops and says I must terminate the program before continuing. I've reset the computer and tried to uninstall immediately afterwards so there was no conflict of programs and it still insists that I terminate the program before continuing. I need some help here.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Aug 2012
    Posts
    7
    My brother is playing on the same connection and his game works fine.
    Reply With Quote Reply With Quote

  5. #5
    Hi,

    Can you try disabling the other computer from the internet and then restarting the client?

    You can also activate selective startup:

    1. Open your start menu and look for Run (Win XP), Start search (Win Vista), or Search programs and files (Win 7).
    2. Delete anything on the Open line that you'll find there, and type in the word MSCONFIG and press the Enter key to bring up the system configuration utility.
    3. Look down the list of startup items (not the tab labeled Startup), and choose Selective Startup.
    4. Once you've chosen Selective Startup, uncheck 'Load Startup Items.'
    5. Once you're done here, click Apply & OK, and let it reboot your computer.

    Try running the game again. If the game loads and seems to be working, the problem is most likely related to one or more programs you have scheduled to load with Windows. You can then revert the settings back the way they were, and in a trial and error fashion, disable some programs using the startup tab (in the msconfig utility) to try to find the culprit.
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Aug 2012
    Posts
    7
    I tried your suggestions and they didn't help. I tried to force a redownload when it checks files by moving the install folder to the desktop. That allowed the launcher to connect somehow and it displayed that all the files were present. What? i moved the file back into the folder and suddenly I could play again. then the patch came out last night and now it will connect to the server but will fail to patch and prompt me to attempt to retry. I click yes and then nothing further happens.
    Reply With Quote Reply With Quote

  7. #7
    I'm suprised nobody has posted any actual fixes for this issue yet, Anyways I have the same problem, launcher says it is unable to connect to server. ubisoft is the most dissapointing piece of shit yet, i'm saying this with lot's of experiences at my own home and friends place, please ubisoft, FIX IT!
    Reply With Quote Reply With Quote

  8. #8
    Quote Originally Posted by Jowers View Post
    I tried your suggestions and they didn't help. I tried to force a redownload when it checks files by moving the install folder to the desktop. That allowed the launcher to connect somehow and it displayed that all the files were present. What? i moved the file back into the folder and suddenly I could play again. then the patch came out last night and now it will connect to the server but will fail to patch and prompt me to attempt to retry. I click yes and then nothing further happens.
    Hey Jowers! Sorry you've been running into these errors. There is an entry in our FAQ about patching errors that you should check out: http://ghost-recon.ubi.com/ghost-rec...t=tcm:6-231-32. If that doesn't help, please send us a support ticket so we can give you some one-on-one assistance. Thank you for your patience and continued interest in playing!

    For those who are still experiencing connection failures, please try performing a DNS flush. Go to start > run > type "cmd" and hit enter > type "ipconfig/flushdns" and hit enter. Here is a FAQ entry that has a couple of other basic suggestions for dealing with connection issues: http://ghost-recon.ubi.com/ghost-rec...t=tcm:6-231-32. Make sure you open TCP ports 80 and 3074 and that GRO is allowed on your firewall and anti-virus software. If you still run into this error, please send us a support ticket and we should be able to help you out. Make sure to include any details about what you have already tried.
    Reply With Quote Reply With Quote

  9. #9
    I can't believe this... It's been a couple years but still there's no answer to this problem. The launcher says it can't connect a dns flush does nothing and the faq still is on in-game issues not before the game is even launched. Occasionally it works for me but then i can't log in once i actually get into the game.
    Reply With Quote Reply With Quote

  10. #10
    Junior Member
    Join Date
    Sep 2013
    Posts
    22
    im with you. Having "Server" related issues.
    Can't login most of the time. The times I can, the launcher shows the 'start game' button as gray and stays that way.
    Nothing has changed on this comp at all, so I know it's not on my end.
    Sadly the GRO servers are the worst I've ever had to deal with.
    Is it REALLY because of Watch Dogs? hmmm..... doubt it since there have always been these problems.
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •